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INTRODUCTION
Welcome
Congratulations on purchasing this Data I/O programmer. You are about to discover
the ease of use and flexibility that make Data I/O programmers the leading choice for
professional users.
This Optima User Manual will lead you through the process of setting up and running
any of these engineering and production products programmers in the Optima family:
Singlesyte
Plus 48
Optima
Optima Light

Multisyte
Dual
Quad
Octal

Whether Singlesyte or Multisyte, all Optima family programmers are controlled with
the same simple, intuitive screen controls of the Optima Windows software.
All Optima family programmers (with the exception of the Plus 48) will accept any of
the interchangeable TOP Socket Modules or Production Adapters. A few of the TOP
Socket Modules and Production Adapters are listed here:
TOP Socket Modules
TOP84PLC
TOP3PLC
TOP44PLC
TOP68PLC
TOP48DIP
TOP432DIP
FlashTOP

Production Adapters
Universal Adapter Base
Universal SOIC Production Adapter
Additional Production Adapters to
support TSOPs, PBGAs, QFPs and
others.
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To use this universal hardware and software you simply connect the programmer and
TOP to your computer, install the software, and you’re ready to begin programming.
Your Windows dialog box will graphically display which programmer and TOP you
are using.
Note: Most of the software commands described in the Optima
User Manual apply to all programmers in the Optima
family. If a command or operation applies to only one of the
programmers, a special Note will alert you. If there is no
special Note, then the same command works with all
programmers.
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System Overview
As a peripheral to your PC, the programmer utilizes the RAM, CPU, and disk drives
in your computer for user interface and data exchange. The programmer comes with
its own power supply (internal or external) and timing circuits for accurate generation
of programming signals.

Standard Features
Standard features of the Optima programmers include:
High Pin Count: Up to 84 pins. Standard 48 pin (300/600 mil) DIP socket
supports devices from 8-48 pins. Additional pin drivers, if required, reside in
the individual TOPs.
Universal ASIC Pin Drivers: These provide precise digital and analog
signals on every pin. Controlled rise times and advanced noise suppression
circuitry assure high quality, reliable programming.
Quick Response: Single keystroke operation and instantaneous file load
times make Optima both quick to learn and easy to use.
Device Support: PROMs, EPROMs, EEPROMs, PLDs, EPLDs, EEPLDs,
GALs, FPLAs, IFLs, MCUs, Flash and more in 3 and 5 volt technologies, and
in various package types.
PC Peripheral: Optima uses the computer’s existing RAM, Disk, Keyboard
and Display to provide maximum price/performance.
Relay Power/Ground: Optimal noise-free device power for highest yields.
Fast Clock: Fast rise times (3 ns) allow reliable vector testing.
State Machine Waveform Generation: Internal crystal controlled statemachine ensures accurate programming waveforms not dependent on PC
timing.
Full Screen Menus: These make the Optima easy to learn and operate.
Customize User Interface Option: All input commands can be executed
from a batch file, or via a network or multitasking Windows environment, on
a local or remote PC.
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Computer Requirements
In order to use your programmer successfully, you will need the following:
x

Windows-based PC, AT, 486, Pentium, Laptop, or Notebook

x

640K RAM (minimum)

x

Hard disk with at least 10 Megabytes of available space

x

VGA or LCD
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Installing the Optima Hardware
Optima programmers arrive with the following components:
x

Programmer base

x

Optional TOPs

x

25 pin, 1:1 parallel cable, 32” length

x

Optima-Booster

x

Power cord

x

Power supply (Plus 48, Optima, Optima Light, Dual)

x

Optima Windows software on CD-ROM

x
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To prepare the Optima programmer for use, remove all the components from the
packaging material and verify that they are in good repair.

Connecting the Programmer to Your Computer
Connect the programmer to your computer by following these steps:
1.

Make sure that both the computer and programmer power switches are turned
OFF.

2.

Connect one end of the parallel cable to the port on the rear of the programmer.

3.

Connect the other end of the parallel cable to the parallel port of your computer.
If your computer has more than one parallel port, any empty port may be used.
Note: Some parallel ports have hardware characteristics that may
cause problems communicating with the programmer. If you
see the message “Found slow printer port” during
installation, install the Optima-Booster supplied with your
programmer. Follow the instructions “Installing the
Optima-Booster for a Slow Printer Port.”
Optima User Manual
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4.

Install the power supply:
x For Plus 48, Optima, Optima Light, and Dual programmers: Insert the small
DIN jack of the power supply into the power connector on the back of the
programmer. This jack is keyed and cannot be inserted incorrectly.
Note: Power supplies for Plus 48, Optima, Optima Light and Dual
are not interchangeable.
x

5.

For Quad and Octal programmers: Connect the main power cord to the
power jack on the back of the programmer.

Insert the other end of the power cord into a 100-250 Volts, 50-60 Hz AC outlet.
Warning: Do not turn on the power
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Connecting the TOPs to Your Programmer
Programmers come with a variety of TOPs. If the TOP that came with your
programmer is not already installed, install it now following these steps:
1.

Turn the TOP over and examine the pins to verify that they are straight.

2.

Hold the TOP at a 45q angle to the programmer base, with the plastic tab of the
TOP hooked into the receiving indentation of the base.

3.

Lower the TOP until it rests lightly on the base.

4.

Rock the TOP gently until it seats into the base.

5.

Press the TOP gently until you hear a click.
Warning: Do not press the TOP if you meet resistance. The pins
may not be properly lined up with the pin connector strip
on the base. If you meet resistance, remove TOP and
begin again at Step 1.
Note: You can arrange the TOPs in any order you want. It is
common to arrange similar TOPs close to each other.

6.

Turn the power switch on the back of the programmer to the ON position.

7.

Turn the power switch on your computer to the ON position.

Optima User Manual
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Installing the Optima Windows Software
Follow these steps to install Optima Windows on your computer:
1.

Insert the Optima Release CD-ROM into the appropriate drive on your computer.
Windows starts the SetupWin.exe installation program and you will see the
Welcome to Data I/O Windows Setup dialog box:

2.

Select one of the listed options, then click OK:

q
q
q

Optima / Optima Light / Multisyte—most cases
Plus 48—if connected to a programmer marked PLUS 48
Create installation disks—if installing onto a PC that does not have a CDROM drive
Note: Do not select the Expert/Multisyte option. It is for older
hardware configurations that are not supported.

3.

Click NEXT as you proceed through the Welcome and ReadMe Information
dialog boxes.
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4.

Choose the destination location. We recommend that you select the default
directory, C:\Optima.

5.

Select TYPICAL on the Set-up Type dialog box.

6.

Select the system folder where you wish to have the Optima software stored.

9

The system creates the Optima window:

7.

Drag the icons for Optima PAL, Optima PROM, Optima PROM432, and Optima
TEST to the Windows desktop.

8.

Close all Optima applications.
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Running Optima Windows Self-Test and Calibration
After Optima Windows is installed you will need to initialize it so it can establish
communications with the programmer and load the basic system configuration.
To run the Optima Windows Self-Test and Calibration, complete the following steps:
1.

Make sure that all Optima applications are closed.

2.

Double-click the Optima Test icon on the desktop to start the Self-Test. The
Self-Test & Calibration dialog box will be displayed:

3.

Follow the instructions in the dialog box, then click OK or YES
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4.

Click YES if the following window appears:

Note: If you see the message “Found slow printer port” during the
Self-Test, install the Optima-Booster according to the
instructions “Installing the Optima-Booster for a Slow
Printer Port.”
When the Self-Test has initialized the system, information such as the programmer’s
serial number, the system type, and maintenance expiration date is displayed:
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5.

Click YES to complete all the system tests. The system configuration and the
results of the tests are displayed on the screen when they are completed.

6.

Close the test software if you are prompted to do so.
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Installing the Optima-Booster for a Slow Printer Port
You may have seen the message “Found slow printer port” during installation or
during the Self-Test. This message means that the parallel port is having a problem
communicating with the programmer. As a solution, your system includes a piece of
hardware called the Optima-Booster, which has extra drive features and filters that
minimize hardware interference.
Follow these steps to install the Optima-Booster:
1.

Make sure that both the computer and programmer power switches are turned
OFF.

2.

Disconnect the parallel cable from the parallel port on the back of your computer.

3.

Connect the PC-SIDE end of the Optima-Booster to the parallel port on your
computer.
The Optima-Booster is keyed and cannot be connected incorrectly.
Warning: Do not connect the Optima-Booster to a COM, SCSI,
or parallel (LPT) port/switch box. Otherwise damage to
the Optima-Booster or PC might result.

4.

Connect the parallel cable to the other end of the Optima-Booster.

5.

Turn the computer and programmer back ON.
Note: Some laptops do not provide enough power to have the
Optima-Booster installed.

Optima User Manual
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QUICK START
Getting Started
Once the Optima software and hardware are successfully installed, you’re ready to
begin programming devices. The QUICK START section of the Optima User Manual
guides you through programming memory or logic devices using Optima PROM,
Optima PAL, or Optima PROM432 software.
First, choose the appropriate software. The software program you use depends on
what type of device you will program, and what type of TOP you will use:
If you will program…
a logic-based device
a memory-based device on a TOP432
all other memory-based devices

then use
Optima PAL software
Optima PROM432 software
Optima PROM software

After you have selected the appropriate software, decide whether you will be filling
the programmer’s RAM with valid programming data by
x reading a Master Device, or
x loading a data file
The following sections take you through a step-by-step process of programming a
device. Find the section which matches your conditions and you’re on your way:
x
x
x
x
x
x

Programming a Memory Device by Reading a Master Device
Programming a Memory Device by Loading a Data File
Programming a Logic Device by Reading a Master Device
Programming a Logic Device by Loading a Data File
Programming a Memory Device on the TOP432 by Reading a Master Device
Programming a Memory Device on the TOP432 by Loading a Data File
Note: An Optima programmer with a TOP48DIP is used in the
examples that follow.
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Programming a Memory Device By Reading A Master Device
If you wish to program a memory-based device and you will be reading a Master
Device, follow this procedure.

SELECT THE DEVICE YOU WISH TO PROGRAM:
Programming begins by selecting the device you wish to program. To select the
device, follow these steps:
1.

Double click the Optima PROM icon on the Windows desktop. The Change
Device window displays a device list for the specific TOP you are using.

2.

Click on the name of the Vendor. When you do that, the Family and Device lists
may change.

3.

Click on the general Family of devices. The Device list may change again based
of the Family you chose.

4.

Click on a device part number from the Device list. In this example, an
AMDAm28F010 is selected:
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5.

Click OK to save that selection and display the Main Programming screen:
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READ A MASTER DEVICE:
After you have selected the device, you are ready to read the Master Device. To read
the Master Device, follow these steps:
1.

Insert the Master Device in the TOP lit with the green LED.

2.

Click Read Device.
Data from the Master Device is loaded into the programmer’s RAM. When the
load operation is complete, the Status area in the Main Programming screen
displays the word PASS and the checksum for the data loaded into RAM is
displayed:
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PROGRAM THE DEVICE
Now that you have loaded valid data into the programmer’s RAM by reading a Master
Device, you’re ready to program the device. To program the device, follow these
steps:
1.

Remove the Master Device from the TOP.

2.

Insert the device you wish to program into the TOP with the green LED.

3.

Click Program. You will be asked if you wish to Start Programming Now.
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4.

Click YES.
When the programming operation is complete, the Status area of the Main
Programming screen displays the word PASS:
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Programming a Memory Device By Loading A Data File
If you wish to program a memory-based device and you will be loading a data file,
follow this procedure.

SELECT THE DEVICE YOU WISH TO PROGRAM:
Programming begins by selecting the device you wish to program. To select the
device, follow these steps:
1.

Double click the Optima PROM icon on the Windows desktop. The Change
Device window displays a device list for the specific TOP you are using.

2.

Click on the name of the Vendor. When you do that, the Family and Device lists
may change.

3.

Click on the general Family of devices. The Device list may change again based
of the Family you chose.

4.

Click on a device part number from the Device list. In this example, an
AMDAm28F010 is selected:
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5. Click OK to save that selection and display the Main Programming screen:
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LOAD A DATA FILE:
After you have selected the device, you are ready to load a data file into RAM. To
load a data file, follow these steps:
1.

Select File > Load from the main menu bar. The Open dialog box is displayed:

2.

Browse through the “List files of type” box and select the appropriate program
data file name from the list on the screen.
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3.

Click OK. The File load options dialog box is then displayed:

4.

Click OK. You’ll be asked Ready to load? Click YES
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5.

After the data has been loaded, you’ll see a screen that reports the status of the
loading:
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PROGRAM THE DEVICE
Now that you have loaded valid data into the programmer’s RAM by loading a data
file, you’re ready to program the device. To program the device, follow these steps:
1.

Insert the device you wish to program into the TOP with the green LED.

2.

Click Program. You will be asked if you wish to Start Programming Now.
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3.

Click YES.
When the operation is complete, you will see the screen shown here:
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Programming a Logic Device By Reading A Master Device
If you wish to program a logic-based device and you will be reading a Master Device,
follow this procedure.

SELECT THE DEVICE YOU WISH TO PROGRAM:
Programming begins by selecting the device you wish to program. To select the
device, follow these steps:
1.

Double click the Optima PAL icon on the Windows desktop. The Change
Device window displays a device list for the specific TOP you are using.

2.

Click on the name of the Vendor. When you do that, the Family and Device lists
may change.

3.

Click on the general Family of devices. The Device list may change again based
of the Family you chose.

4.

Click on a device part number from the Device list. In this example, a Lattice
GAL20RA10 is selected:
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5.

Click OK to save that selection and display the Main Programming screen:
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READ A MASTER DEVICE:
After you have selected the device, you are ready to read the Master Device. To read
the Master Device, follow these steps:
1.

Insert the Master Device in the TOP lit with the green LED.

2.

Click Read Device.
Data from the Master Device is loaded into the programmer’s RAM. When the
load operation is complete, the Status area in the Main Programming screen
displays the word PASS and the checksum for the data loaded into RAM is
displayed:
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PROGRAM THE DEVICE
Now that you have loaded valid data into the programmer’s RAM by reading a Master
Device, you’re ready to program the device. To program the device, follow these
steps:
1.

Remove the Master Device from the TOP.

2.

Insert the device you wish to program into the TOP with the green LED.

3.

Click Program. You will be asked if you wish to Start Programming Now.
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4.

Click YES.
When the programming operation is complete, the Status area of the Main
Programming screen displays the word PASS:
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Programming a Logic Device By Loading A Data File
If you wish to program a logic-based device and you will be loading a data file, follow
this procedure.

SELECT THE DEVICE YOU WISH TO PROGRAM:
Programming begins by selecting the device you wish to program. To select the
device, follow these steps:
1.

Double click the Optima PAL icon on the Windows desktop. The Change
Device window displays a device list for the specific TOP you are using.

2.

Click on the name of the Vendor. When you do that, the Family and Device lists
may change.

3.

Click on the general Family of devices. The Device list may change again based
of the Family you chose.

4.

Click on a device part number from the Device list. In this example, a Lattice
GAL20RA10 is selected:
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5.

Click OK to save that selection and display the Main Programming screen:
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LOAD A DATA FILE:
After you have selected the device, you are ready to load a data file into RAM. To
load a data file, follow these steps:
1.

Select File > Load from the main menu bar. The File Open dialog box is
displayed:

2.

Browse through the Files list and select the appropriate program data file name.
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3.

Click OK. The Main Programming screen is then displayed:
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PROGRAM THE DEVICE
Now that you have loaded valid data into the programmer’s RAM by loading a data
file, you’re ready to program the device. To program the device, follow these steps:
1.

Insert the device you wish to program into the TOP with the green LED.

2.

Click Program. You will be asked if you wish to Start Programming Now.
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3.

Click YES.
When the programming operation is complete, the Status area of the Main
Programming screen displays the word PASS:
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Programming a Memory Device on the TOP432 By Reading A
Master Device
If you wish to program a memory-based device on the TOP432 and you will be
reading a Master Device, follow this procedure.

SELECT THE DEVICE YOU WISH TO PROGRAM:
Programming begins by selecting the device you wish to program. To select the
device, follow these steps:
1.

Double click the Optima PROM432 icon on the Windows desktop. The Change
Device window displays a device list for the TOP432.

2.

Click on the name of the Vendor. When you do that, the Family and Device lists
may change.

3.

Click on the general Family of devices. The Device list may change again based
of the Family you chose.

4.

Click on a device part number from the Device list. In this example, an
AMDAm28F010 is selected:
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5.

Click OK to save that selection and display the Main Programming screen:
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READ A MASTER DEVICE:
After you have selected the device, you are ready to read the Master Device. To read
the Master Device, follow these steps:
1.

Insert the Master Device in the upper left-hand socket of the TOP432.

2.

Click Read Device.
Data from the Master Device is loaded into the programmer’s RAM. When the
load operation is complete, the Status area in the Main Programming screen
displays the word PASS and the checksum for the data loaded into RAM is
displayed:
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PROGRAM THE DEVICE
Now that you have loaded valid data into the programmer’s RAM by reading a Master
Device, you’re ready to program the device. To program the device, follow these
steps:
1.

Remove the Master Device from the TOP432.

2.

Insert the devices you wish to program into the four sockets of the TOP432.

3.

Click Program. You will be asked if you wish to Start Programming Now

.
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4.

Click YES.
When the programming operation is complete, the Status area of the Main
Programming screen displays the word PASS:
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Programming a Memory Device on the TOP432 By Loading A
Data File
If you wish to program a memory-based device on the TOP432 and you will be
loading a data file, follow this procedure.

SELECT THE DEVICE YOU WISH TO PROGRAM:
Programming begins by selecting the device you wish to program. To select the
device, follow these steps:
1.

Double click the Optima PROM432 icon on the Windows desktop. The Change
Device window displays a device list for the TOP432.

2.

Click on the name of the Vendor. When you do that, the Family and Device lists
may change.

3.

Click on the general Family of devices. The Device list may change again based
of the Family you chose.
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4.

Click on a device part number from the Device list. In this example, an
AMDAm28F010 is selected:
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5. Click OK to save that selection and display the Main Programming screen:
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LOAD A DATA FILE:
After you have selected the device, you are ready to load a data file into RAM. To
load a data file, follow these steps:
1.

Select File > Load from the main menu bar. The Open dialog box is displayed:

2.

Browse through the “List files of type” box and select the appropriate program
data file name from the list on the screen.

3.

Click OK. The File load options dialog box is then displayed:
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4.

Click OK. You’ll be asked Ready to load? Click YES

5.

After the data has been loaded, you’ll see a screen that reports the status of the
loading:
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PROGRAM THE DEVICE
Now that you have loaded valid data into the programmer’s RAM by loading a data
file, you’re ready to program the device. To program the device, follow these steps:
1.

Insert the devices you wish to program into the four sockets of the TOP432.

2.

Click Program. You will be asked if you wish to Start Programming Now.
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3.

Click YES.
When the programming operation is complete, the Status area of the Main
Programming screen displays the word PASS
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OPTIMA PROM SOFTWARE
This section of the Optima User Manual provides detailed descriptions of the Optima
PROM software used for programming memory devices. If you wish to get started
programming memory devices quickly, go to the QUICK START section of the
Optima User Manual.

Main Programming Screen
Once the device has been selected, the Main Programming screen will appear. This
screen will provide you with programming information and controls.

PROM software Main Programming screen
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The Main Programming screen is divided into these areas:
x

File—contains information regarding the checksum of the data currently in RAM
and the usable address range of the device. If a TOP432 is installed, the Mode:
item will display its GANG or SET mode settings.

x

Device—contains information related to the device to be processed. The
Devicecode: field contains a unique identification code for the device selected.
This code is used by the optional TaskLink Windows software.

x

OPTIMA Xx/XX—contains information about the PROM/PROM432 software
version, the TOPs installed on the programmer base and the status of each, and
the programming mode (single, gang, or swap).

x

Status—provides the status of the last device programmed
(PASS/FAIL/CHECK), the total number of devices to be processed (this field is
editable), and the number of devices remaining to be processed.

x

Device Action—provides quick access to the most commonly used operations.
There are buttons for Program, Read Device, Blank Check, and Verify
operations.

x

Additional information—contains any additional information that may be
required to process the selected devices, such as a specialized adapter, etc.

x

Next Ser.-No.—contains the next serial number to be applied to the device if the
serialization option has been enabled.

x

Messages—contains any additional messages that describe various conditions
related to the processing of the selected device. Messages that may appear
include references to specialized adapters, settings that have been changed to
their non-default conditions, and others.
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The File Menu
The first menu on the Main Programming screen is the File menu. The File menu has
two primary functions: loading data into RAM, and saving data from RAM.
Additionally, the PROM software can be terminated from this menu using the Exit
function:

The File menu
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File>Load
Selecting File>Load will produce the Open dialog screen:

The Open dialogue
The Open dialogue allows the use of these different data formats:
x
x
x
x
x
x
x

Binary (*.com, *.bin)
Hex (*.hex, *.obj, *mot, *.S*) which supports data formats in Motorola
Exorciser, Motorola ExorMax, Motorola 32 (S3), Intel Intellec 8/MDS, Intel
MCS-86 Hex, Intel OMF 286, and Intel Hex-32
Space (*.spc) which supports ASCII Hex Space
MOS (*.mos) which supports MOS Technology
LOF (*.lof) which supports Quick Logic
Actel (*.dio)
HP64000 (*.hp) which supports HP64000 Absolute and HP Unix
Note: If Hex or HP Format is selected, the Optima software
automatically selects the appropriate format.
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If your data file does not use any of the predefined file
extensions, you can wild card the file name by using (*.*) in
the file name box and choosing the appropriate file type.
Navigate the computer or network for the required data file, and select the <OK>
button. Once the file is selected, the File load options screen will appear:

File load options screen
This dialogue provides options for file starting address, device memory destination,
file mode, and data format.
File Load Options
For most file load operations you will accept the default values when the File load
options dialog box appears by clicking on <OK>. However, the File load options
dialog box has four option menus that allow you to customize the file load operation:
x
x
x
x

Start address in file
Destination in memory
File mode
Intel/Motorola format
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Start address in file:
If a hexadecimal number is placed in the Start address in file box prior to a file load
operation, the load software waits until that address is reached before placing data into
the Optima Ram Buffer.
In Example 1 below, the Start address in file has been set to 300 hex, and therefore
the load software waits until address 300 hex has been reached before placing data
into the Optima Ram Buffer starting at location zero.
Start address in file works for all formats.
Example 1: Start address in file
File Data (ASCII Hex Space)
$A000,
00 01 02 03 04 05 06 07
$A100,
08 09 0A 0B 0C 0D 0E 0F
$A200,
00 11 22 33 44 55 66 77
$A300,
88 99 AA BB CC DD EE FF

Start address in file = 300 Hex
xx = Don’t Care
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Optima Ram Buffer
Address
0000
0001
0002
0003
0004
0005
0006
0007
0008
0009
000A
000B
000C
000D
000E
000F

Data
88
99
AA
BB
CC
DD
EE
FF
xx
xx
xx
xx
xx
xx
xx
xx
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Destination in memory:
The hex value placed in the Destination in memory determines the starting point in the
Optima Ram Buffer where data will be stored.
Destination in memory works for all file formats.
In Example 2 below the Destination in memory value is set to 800 hex; this causes the
start of the data file to be placed at 800 hex in the Optima Ram Buffer.
Example 2: Destination in memory
File Data (ASCII Hex Space)
$A000,
00 01 02 03 04 05 06 07
$A008,
08 09 0A 0B 0C 0D 0E 0F
$A010,
00 11 22 33 44 55 66 77
$A018,
88 99 AA BB CC DD EE FF

Destination in memory = 800 Hex
xx = Don’t Care

Optima Ram Buffer
Address
0000
0100
0200
0300
0400
0500
0600
0700
0800
0801
0802
0803
0804
0805
0806
0807

Data
xx
xx
xx
xx
xx
xx
xx
xx
00
01
02
03
04
05
06
07

Optima User Manual

58 OPTIMA PROM SOFTWARE
File mode:
This option allows you to rearrange the file data so that the data will fit in the
targeted-programmed device. For example, a 16-bit data file has to be programmed
into two 8-bit devices. File mode has five different ways to rearrange data:
x
x
x
x
x

8-Bit All—No effect on the incoming data.
8 Bit Merge Low and High—Used to merge two 8-bit files into one 16-bit file.
16-Bit Even and Odd—Used to program a 16-bit data file into two 8-bit devices.
32-Bit Byte 0, Byte 1, Byte 2, Byte 3—Used to program a 32-bit data file into
four 8-bit devices.
32-Bit Low and High Word—Used to program a 32-bit data file into two 16-bit
devices.

8-Bit All
With 8-Bit All, the file data that is read is transferred directly into the Optima Ram
Buffer, as shown in Example 3 below.
Example 3: 8-Bit All
File Data
$A000,
00 01 02 03 04 05 06 07
$A008,
08 09 0A 0B 0C 0D 0E 0F
$A010,
00 11 22 33 44 55 66 77
$A018,
88 99 AA BB CC DD EE FF
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Optima Ram Buffer
Address
0000
0001
0002
0003
0004
0005
0006
0007
0008
0009
000A
000B
000C
000D
000E
000F

Data
00
01
02
03
04
05
06
07
08
09
0A
0B
0C
0D
0E
0F
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8-Bit Merge Low and High
This option is used to merge two 8-bit data files into one 16-bit data file, allowing a
16-bit device to be programmed.
To merge two 8-bit files into one 16-bit file, follow this four step process:
1. Select the first 8-bit file, choose 8-Bit Merge Low, and load your file.
The 8-bit data will be loaded at all the even addresses (shown in bold below).
2. Select the second 8-bit file, choose 8-Bit Merge High, and load the file.
The 8-bit data will be loaded at all the odd addresses. (shown in italics below).
3. Program the 16-bit memory device.
4. Save the newly created 16-bit data file.
Example 4: 8-Bit Merge Low and High
File Data
$A000, (8-Bit file one)
00 01 02 03 04 05 06 07
$A008,
08 09 0A 0B 0C 0D 0E 0F
$A000, (8 Bit file two)
00 11 22 33 44 55 66 77
$A008,
88 99 AA BB CC DD EE FF

Optima Ram Buffer
Address
0000
0001
0002
0003
0004
0005
0006
0007
0008
0009
000A
000B
000C
000D
000E
000F

Data
00
00
01
11
02
22
03
33
04
44
05
55
06
66
07
77
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16-Bit Even and Odd
This option is used to split a 16-bit data file into two 8-bit data files.
To split a 16-bit data file into two 8-bit data files, follow this four step process:
1. Select the 16-bit data file that is to be split into two 8-bit files, select 16-Bit Even,
and load the file.
All the even data bytes will be loaded into the Optima Ram Buffer (as shown in
bold below).
2. Program the 8-bit memory device.
3. Repeat the file download operation, but select 16- Bit Odd.
All the odd data bytes will be loaded into the Optima Ram Buffer (shown in
italics below).
4. Program the second 8 bit memory device.
Example 5: 16-Bit Even and Odd
File Data
$A000, (8-Bit file one)
00 01 02 03 04 05 06 07
$A008,
08 09 0A 0B 0C 0D 0E 0F
$A010,
00 11 22 33 44 55 66 77
$A018,
88 99 AA BB CC DD EE FF
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Optima Ram Buffer
16-Bit Even Selected
Address
Data
0000
00
0001
02
0002
04
0003
06
0004
08
0005
0A
0006
0C
0007
0E
0008
00
0009
22
000A
44
000B
66
000C
88
000D
AA
000E
CC
000F
EE

Optima Ram Buffer
16-Bit Odd Selected
Data
01
03
05
07
09
0B
0D
0F
11
33
55
77
99
BB
DD
FF
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32-Bit Byte0…Byte3
This option is used to split a 32-bit data file into four 8-bit data files.
To split a 32-bit data file into four 8-bit data files, follow this eight-step process:
1. Select the 32-Bit data file that is to be split into four 8-bit files, select 32-Bit Byte
0, and load the file. Data bytes D0-D7 will be loaded into Optima Ram Buffer
(shown in bold).
2. Program the first 8-bit memory device.
3. Repeat the file download operation, and select 32-Bit Byte 1.
Data bytes D8-D15 will be loaded into the Ram Buffer (shown in italics).
4. Program the second 8-bit device.
5. Repeat the file download operation, and select 32-Bit Byte 2.
Data bytes D16-D23 will be loaded into the Ram Buffer (shown in underline).
6. Program the third 8-bit device.
7. Repeat the file download operation a forth time, and select 32-Bit Byte 3.
Data bytes D24-D31 will be loaded into the Ram Buffer (shown in regular).
8. Program the fourth 8-bit device.
Example 6: 32-Bit Byte0…Byte3
File Data
$A000,
00 01 02 03 04 05 06 07
$A008,
08 09 0A 0B 0C 0D 0E 0F0003
$A010,
00 11 22 33 44 55 66 77

Byte 0
Address
0000
0001
0002
0C
0004
0005
0006
0007

Data
00
04
08
0D
00
44
88
CC

Ram Buffer
Byte 1 Byte 2
Data
Data
01
02
05
06
09
0A
0E
0F
11
22
55
66
99
AA
DD
EE

Byte 3
Data
03
07
0B
33
77
BB
FF

$A018,
88 99 AA BB CC DD EE FF
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32-Bit Low and High Word
This option is used to split a 32-bit data file into two 16-bit data files.
To split a 32-bit data file into two 16-bit data files, follow this four step process:
1. Select the 32-bit data file to be split into two 16-bit files, select 32-Bit Low Word
and load the file.
All the low-order data words will be loaded into Optima Ram Buffer (shown in
bold).
2. Program the 16-bit memory device.
3. Repeat the file download operation, and select 32-Bit High.
All the high order data words will be loaded into the Ram Buffer (shown in
italics).
4. Program the second 16-bit device.
Example 7: 32-Bit Low and High Word
File Data
$A000,
00 01 02 03 04 05 06 07
$A008,
08 09 0A 0B 0C 0D 0E 0F
$A010,
00 11 22 33 44 55 66 77
$A018,
88 99 AA BB CC DD EE FF
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Optima Ram Buffer
Low Word Selected
Address Data
0000
00
0001
01
0002
04
0003
05
0004
08
0005
09
0006
0C
0007
0D
0008
00
0009
11
000A 44
000B 55
000C 88
000D 99
000E CC
000F
DD

Optima Ram Buffer
High Word Selected
Data
02
03
06
07
0A
0B
0E
0F
22
33
66
77
AA
BB
EE
FF
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Intel/Motorola Format:
This option is used to do an odd/even byte swap as data is loaded. By selecting Intel
Little Endian (default value), the data is loaded directly into memory. By selecting
Motorola Big Endain, an odd/even byte swap is performed before the data is stored in
the Ram Buffer.
Note: Versions of Optima software after B/99 have a Byte Swap
feature located under the Memory menu. This feature can
also be used after a file download.

Example 8: Intel/Motorola Format
File Data
$A000,
00 01 02 03 04 05 06 07
$A008,
08 09 0A 0B 0C 0D 0E 0F
$A010,
00 11 22 33 44 55 66 77
$A018,
88 99 AA BB CC DD EE FF

Optima Ram Buffer
Intel Little Endian
Address
Data
0000
00
0001
01
0002
02
0003
03
0004
04
0005
05
0006
06
0007
07
0008
08
0009
09
000A
0A
000B
0B
000C
0C
000D
0D
000E
0E
000F
0F

Optima Ram Buffer
Motorola Big Endian
Data
01
00
03
02
05
04
07
06
09
08
0B
0A
0D
0C
0F
0E
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File>Save As
There is also an option for saving the data in RAM as a data file. This can be helpful
when you have a master device but no data file, and you would like to create one.
Selecting File> Save As will produce the following screen:

The Save-As dialogue
You may save data files in the following formats:
x
x
x

Binary (*.com, *.bin)
Intel MCS-86 Hex
ASCII Hex Space (*.*)

After loading a data file or reading a master device, select Save As from the File
menu, select the appropriate file format, name the file, and save it to the desired
location.
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The Memory Menu
The second menu on the Main Programming screen is the Memory menu. The
Memory menu provides you with a method to view and/or modify the contents of
memory at any time before or after the programming operation.

The Memory menu
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Memory>Edit
Selecting Memory>Edit will display the following screen:

Dump/Edit memory
Hexadecimal memory locations are displayed with ASCII equivalents to the right.
The editor has two editing modes: hexadecimal and ASCII. Edit by placing the cursor
where you want to begin and click once. If the hexadecimal editor is chosen, values 09, or A-F can be entered from the keyboard. If the ASCII editor is chosen, then any
value from the keyboard can be entered. To move to higher memory locations, use
the vertical scroll bar on the right side of the memory window.
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As noted in the lower-right corner of the Dump/Edit screen, you may press the right
mouse button for additional editor features:

Right-clicking in the edit screen displays additional editing options
The edit screen provides several useful additional features including:
x
x

Print—Allows you to print contents shown on the screen
Printer-Setup—Allows you to choose the desired printer and its configuration
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x

Goto Address…—Allows you to jump to any address in the memory array, as
shown here:

Goto Address menu function allows you to jump to any memory location
x

Fill…—Allows you to fill the memory array with any data pattern, as shown
here:

Fill function allows you to fill the memory array with any data pattern
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NOTE: The Fill memory menu item accepts values in relation to the
device to be processed. It is often necessary to know the
block size of the specific device being used. Many devices
do not support partial programming operations. Therefore,
partially filling RAM with a data pattern is not supported
with those devices. Because of this, an error will occur if
you attempt to fill RAM with less data than the device
supports. Also, filling RAM beyond the block size of the
device will produce a similar error.
x
x

Swap bytes—Allows you to transpose high and low order bytes within the data
file
Search for byte—Allows you to search the memory array for a specific data
string.
Selecting Search for Byte produces this window:

“Search for byte” allows you to locate a hex string within memory array
x

Repeat search—Performs the Search for byte operation again with the
previously entered search data

You may also select Memory>Fill to fill memory with a hexadecimal data pattern.
Once selected, the following screen will appear:

Memory>Swap Bytes
In cases where the data bytes must be reversed in the data file to accommodate a
specific device, select Memory> Swap Bytes (or select Memory>Edit and right
click to select Swap Bytes). This function allows you to transpose odd and even order
bytes within the data file.
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Memory>Address Range
For devices that support partial operations, or if the data file is required to begin at a
specific location, the Address Range… menu item may be used to establish the
programming area of the device. Selecting the Memory>Address Range… produces
the following dialogue:

Setting the device address range
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In this dialogue, you can specify the starting and ending addresses. In the example
shown, the start address is set to 100:

Start address set to 100
The file load operation will cause data to be loaded starting at address location hex
100. If a programming operation is performed, data will be programmed from location
100 to 1FFFF
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Memory>Checksum Options…
The Checksum Options…menu item is used to set the number of characters
representing the data checksum, ranging from four to eight characters.
Selecting Memory>Checksum Options… will produce this screen:

Setting the checksum options
Here you have the option to select a 4 to 8 digit hexadecimal checksum. Checking the
Calculation of checksum with special bytes adds the special bytes to the displayed
checksum.
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Memory>Special Device Functions…
The Special Device Functions…menu item is used to set features unique to the
devices under test. This feature is enabled only for devices with special features.
Additionally, these features vary from device to device.

Setting special device functions
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Memory>Device Serialization Options…
The Device Serialization Options…allows you to assign unique electronic serial
numbers to each device being programmed. When serializing devices, the serial
number is automatically incremented for the next device each time the Optima
software completes a programming operation. When serializing with Multisyte
programmers (Dual, Quad, and Octal) in gang mode, sequential serial numbers are
automatically generated for devices inserted into adjacent TOPs.
Note: Serialization is only supported with single-socket TOPs, such
as the TOP48, TOP84PLC, and other similar TOPs. It is not
supported on the TOP432
or Flash TOP.
To set up this feature, refer to the figures below and perform the following process:
1.

Select Memory > Device Serialization Options… The following screen will
appear:

Selecting the serial number file
2.

Choose the path and serial number file you would like to use, or if creating a new
serial number file, type in the desired name of the file in the File name field. For
clarity, use DOS standard 8.3 file names. The default file extension for serial
number files is *.sn, but can be anything you like. To locate files with extensions
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other than *.sn, select All (*.*) from the List files of type pull-down menu in the
lower left of the window.
3.

Select <OK>. A Serialization Options screen appears:

The Serialization Options screen
Editable fields include:
x
x

S/N Options file—The name of the serial number file that was selected or
created from the previous screen.
Next S/N—The starting serial number of the next device to be programmed; this
is a decimal number. Numbers entered here will automatically be converted to
the correct format when the device is programmed.
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x

S/N stored in—Selects the format that the serial number data will be written to
the device; choices are HEX (each digit from 0h to Fh), ASCII (each digit from
30h to 39h), and BCD (00002 to 10012).

Selecting the format to store serial number data
x

S/N Digits—Selects the number of characters, in decimal, used for the serial
number format. The maximum number of characters is:
q 8 for S/Ns stored in HEX (FFFFFFFFh); S/Ns 0 through 4,294,967,295
q 9 for S/Ns stored in ASCII (393939393939393939h); S/Ns 0 through
999,999,999
q 8 for S/Ns stored in BCD (99999999h); S/Ns 0 through 2,576,980,377
Note: The S/N Digits value indicates the number of hex characters
that are permitted to exist as a serial number in the memory
array. The exception to this rule is the ASCII format, in
which the number represents hex bytes. While this appears
complicated, as long as the serial number limits are not
exceeded, no errors will occur.

x

Serial Number Start Addr.—The hexadecimal address in the memory array
where the first byte of the serial number will be placed. All characters of the
serial number must fit within the memory array of the device or serialization will
not take place.
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x
x

Byte Order—Used to select the order that the serial number data is placed in the
device as related to the data file; choices include Big Endian (Hi byte/Lo byte—
Motorola) and Little Endian (Lo byte/Hi byte—Intel).
Word Mode—Set when a serial number byte is to extend to the word width of
the device. If word mode is set to:
q Off—The default byte width of 8 bits is used.
q On—One byte of the serial number data will occupy the width of the
data path. If the data width of the device is 16 bits wide, then one byte
of the serial number will also be 16 bits wide. For unique devices, such
as some Microchip Technology devices, the word width may be 12 or 14
bits.

Selecting the byte order of a data file
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x

Store S/N bytes—This setting specifies which bytes are written to the memory
array and in which order. The selections are:
q All—All bytes of the serial number are written to the memory array.
q Even—Only the even bytes of the serial number are written. If this
option is selected, then the number of serial number digits (selected in
S/N Digits) must be even (2, 4, 6, or 8).
q Odd—Only the odd bytes of the serial number are written. If this option
is selected, then the number of serial number digits must be even (2, 4, 6,
or 8).
q 0 of four, 1 of four, 2 of four, 3 of four—Only bytes in the
corresponding byte position in the serial number are written. For
example, if a HEX serial number of 00BC614Eh is generated, when 1 of
four is selected, BCh (byte #1 of four bytes total) is written to the
designated start address. The largest hexadecimal serial number allowed
is FFFFFFFFh, or 4,294,967,29510. The largest BCD serial number
allowed is 99999999h, or 2,576,980,37710

Selecting the method of storing serial number bytes
Note: The X of four mode works only with hexadecimal and BCD
serial number types as selected in the S/N stored in field.
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Selecting ASCII as a serial number value type will return an
error.

The Device Menu
The third menu on the Main Programming screen is the Device menu. This menu
provides you with basic operational commands as shown in the figure below:

The Device menu
The Program, Read, Blank Check, and Verify commands can be initiated from this
menu.

Optima User Manual

80 OPTIMA PROM SOFTWARE

Device>Program
Selecting Device>Program produces the following dialogue:

Starting the Program routine
Selecting <Yes> begins the programming operation; <No> stops the programming
operation.
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Upon successful completion of the programming operation, PASS will appear in the
Status area indicating proper programming:

Programming operation has passed
Any special information related to the programming operation will appear in the
Messages text area at the bottom of the screen.
The first process performed on the device during the Program operation is a check for
blank state. If the device is EEPROM based, then an erase cycle will be executed
automatically. If it is not erased and is UV-erasable or is a one-time programmable
(OTP) device, the Optima software will test to see if the pattern in memory can be
over-programmed (that is, new data is programmed on top of the existing pattern in
the device). If over-programming is possible, then you will be asked Skip blank check:
Yes/No. If you select <YES>, then the device will be over-programmed. If you select
<No>, you will receive a “Device not blank” error message, and the Program
operation will stop.
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After the automatic blank check is completed, the device will then be programmed
using the algorithm defined by the manufacturer. Intelligent programming is used to
keep programming time to a minimum. The intelligent programming algorithm is
selected automatically when the device type is selected.
After programming, the device will be verified to confirm proper programming. If
there are any errors in verification, you can create a detailed report of the errors on the
screen (see Device>Verify section). If the device vendor specifies it, verification will
be done at the Vcc high and Vcc low levels in accordance with manufacturer’s
specifications.
If the device is improperly inserted into the socket, the device is defective, or the
programming TOP is faulty, then a continuity message appears:

Continuity error
A yellow light on the TOP itself, as well as a yellow light on the TOP icon on the
Main Programming screen, identifies the socket with the continuity error. The
software prompts you to <Display> the pin(s) in error, <Cancel> the operation,
<Retry> the operation, or <Ignore> the error and continue.
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The Optima software contains a convenient tool for isolating the cause of a continuity
failure. Selecting the <Display> option presents you with a package diagram
outlining the pin(s) that are believed to be causing the failure:

Pinmap showing continuity failures; pins displayed here in gray are not making
proper contact. On user interface, pins not making proper contact are displayed in
red.
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Device>Read
Selecting Device>Read retrieves the data contents of the device in the socket and
reads them into memory. While the read operation is in progress, the status window
displays the term ACTIVE and shows the percentage of completion. When the read
operation is complete, a PASS or FAIL message indicates its success or failure. Using
the <Read Device> button in the Device Action section yields the same results. Any
additional information related to this read operation is also displayed in the Messages
section of the screen:

Successful completion of a READ operation
When using a Multisyte programmer, insert the device in the left-most TOP for the
read operation.
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Device>Blank Check
The Blank Check feature may be enabled or disabled depending on the device
selected. If the feature is enabled, selecting Device>Blank Check lets you determine
if the device under test is truly empty. If the blank check passes, the device is truly
empty. Otherwise, some of the device locations may have data in them.
UV erasable devices must be erased under ultraviolet light in accordance with the
manufacturer’s instructions before programming.
Note: Not all UV erasable devices are guaranteed to arrive blank
from the manufacturer. If they are not blank, simply erase
them according to the manufacturer’s guidelines for the
device under test.
The Blank Check function is performed prior to all programming functions. You may
also initiate the Blank Check operation from the <Blank Check> button in the Device
Action section of the screen.
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Device>Verify
Devices may also be verified with known good data by selecting Device>Verify To
use this function, you must first read the device’s data into the programmer/software
RAM. The data can be read two different ways:
x Select Device>Read to read a master device into programmer/software RAM.
x Select File>Load to load a data file into programmer/software RAM.
Once the data to be verified has been successfully loaded into programmer/software
RAM, insert the device into the programmer socket. Select Device>Verify, or click
the <Verify> button in the Device Action section of the screen to initiate the Verify
action. During the Verify action, a byte-by-byte comparison is performed between the
data in RAM and the device in the socket. When the Verify action is complete,
PASS/FAIL results will be displayed in the Status section of the screen, as well as in
the Messages section

Device Verify Pass message
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If you get an error message, the following screen will identify the address from RAM
and PROM and data information where errors occurred:

Device verification errors are displayed with location information
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The Select Device Menu
The fourth menu on the Main Programming screen is the Select Device menu.

The Select Device menu
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The Select Device menu allows you to select the type of device you wish to program.
When selected, the Change Device screen appears:

Selecting the device to be programmed
Select the vendor, family and device to be processed from the list and click <OK>.
The devices listed are those that are supported by the TOP that has been installed. If
you do not find the device on the list, follow these steps:
1.
2.
3.
4.

Turn off power to the programmer
Close the software
Remove the TOP
Install a TOP that supports the device you wish to program
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If you see TOP! next to the vendor name, no device manufactured by that vendor is
supported by the TOP you have installed. For example, the TOP48 does not support
any Actel devices, as shown here:

Vendor not supported by this TOP
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If you see TOP! beside the family name, devices in that family are not supported by
the TOP you have installed. For example, the TOP48 does not support the family of
MB 7 devices. By reading the Sxxx number beside the device listed, you can
determine which TOP does support the device you wish to program:

MB 7 device family not supported by this TOP
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If you see Sxxx beside the device name, that device is not supported by the TOP you
have installed. For example, the TOP48 does not support Hitachi HD647325, as
shown here:

Device not supported by this TOP
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If you see SMP beside the device name, your current level of support does not include
this device and needs to be updated. To update your level of support, see the
SOFTWARE MAINTENANCE PLAN section of the Optima User Manual.

Level of support does not include this device
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The Options Menu
The fifth menu on the Main Programming screen is the Options menu.

The Options menu
Many programming operations are adjustable through the Options menu. Among
these are verify operation parameters, blank check, electronic erase, continuity checks,
electronic ID checks, specific algorithm parameters, checksum options, and various
special functions.
Note: Many of the options displayed in the Options menu are
device specific and may not be available for all
programming operations. In the example above, a UV
erasable device has been selected, and the EErase menu item
is not available.
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The following items can be found in the Options menu:
x

Verify Off, Verify Normal, Verify High/Low—Used to set the method of
device data verification after programming.
q
q
q

Verify Off provides no verification of the device after programming
Verify Normal provides a single-pass verify at nominal VCC for the
device after programming
Verify High/Low provides a two-pass verify; first at device-rated low
VCC, and second at device-rated high VCC

x

Blank Check—Adds a Blank Check operation to the programming operation. If
a device is not blank during the programming operation, a message will appear
notifying you that the device in use is not blank. If you choose to continue, the
device will be over-programmed. This option will not be available with
electrically-erasable devices.

x

EErase—Adds an Electrical Erase operation to the programming operation if the
function is supported with the selected device. This option will not be available
for UV erasable devices and one-time-programmable (OTP) devices.

x

Continuity Check—If enabled, checks for proper device continuity before a
programming operation. Continuity errors will present the standard continuity
warning message and will allow you to display the pins in question. This option
should not be turned off unless there is a known reason to do so.

x

ID Check—Allows for checking for the manufacturer’s electronic ID prior to
programming. As a safety-net style of operation, many manufacturers assign
their devices a unique identification number. Occasionally, when manufacturers
change a physical or electrical specification for a device, they may also change
the electronic ID of that device.
For example, if a modification in die size also requires a change in the
programming algorithm to increase performance or compatibility, the
manufacturer may change the electronic ID. When electronic ID is turned ON,
this change can be detected, and the device manufacturer can be contacted to
verify that a change has taken place. If the change is significant, a new algorithm
may need to be developed to support this new device configuration.
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Note: If the device ID is different from that which the algorithm
expects, the programmer software may not allow you to
continue until the discrepancy is corrected.
If the device is determined to require no algorithm changes, electronic ID may be
turned OFF until such time that the algorithm may be updated to incorporate the
new electronic ID. Additionally, ID Check may be set to AUTO to automatically
detect the electronic ID of those devices supporting this option.
x

Algorithm Options—Used to change specific programming parameters within
the algorithm.
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The Utilities Menu
The sixth menu on the Main Programming screen is the Utilities menu.

The Utilities Menu
You can create a complete list of devices supported by the Optima family
programmers by using the Utilities menu.
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Utilities>Create Devicelist
To create a device list, select Utilities>Create Devicelist. The following screen
appears:

Attention screen
Click <Yes> to continue.
A file titled “dev_prm.txt” is then created in your Optima directory. It lists all the
programmable memory and microcontroller devices supported for the installed
version of Optima software. The “dev_prm.txt” file is tab delimited and can be
imported into an Excel spreadsheet. Once imported, use Excel to filter the file to
create a device list that meets your specific needs:

Excel spreadsheet device list (portion)
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The Help Menu
The seventh menu on the Main Programming screen is the Help menu.

The Help menu
The Help menu provides assistance with commonly used features and functions of the
Optima software. This menu function may not be available in early versions of the
Optima software. To ensure that you are using the latest revision of programmer
software, download the programmer updates from Data I/O’s web site.
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OPTIMA PAL SOFTWARE
This section of the Optima User Manual provides detailed descriptions of the Optima
PAL software used for programming logic devices. If you wish to get started
programming logic devices quickly, go to the QUICK START section of the Optima
User Manual.

Main Programming Screen
Once the device has been selected, the Main Programming screen for the Optima PAL
software will appear:

PAL software Main Programming screen

Optima User Manual

102 OPTIMA PAL SOFTWARE
The Main Programming screen is divided into these areas:
x

File—contains information regarding the checksum of the data currently in RAM
and the usable address range of the device

x

Device—contains information related to the device to be processed. The
Devicecode: field contains a unique identification code for the device selected.
This code is used by the optional TaskLink Windows software.

x

OPTIMA Xx/XX—contains information about the PAL software version, the
TOPs installed on the programmer base, and the programming mode (single,
gang, or swap).

x

Status—provides the status of the last device programmed
(PASS/FAIL/CHECK), the total number of devices to be processed (this field is
editable), and the number of devices remaining to be processed.

x

Device Action—provides quick access to the most commonly used operations.
There are buttons for Program, Read Device, Blank Check, Verify, Secure Device
and Test operations.

x

Additional information—contains any additional information that may be
required to process the selected devices, such as a specialized adapter, etc.

x

Messages—contains any additional messages that describe various conditions
related to the processing of the selected device. Messages that may appear
include references to specialized adapters, settings that have been changed to
their non-default conditions, and others.

The area titled Optima Xx/XX contains several controls that determine the site(s) to
be used for programming, the TOPs installed on the site(s), and the programming
modes of operation. This section contains a virtual layout of the programmer in use.
If the programmer is an Optima Light, then one programmer site is shown, and the
TOP that has been installed is shown. If the programmer is an Octal, then eight sites
are displayed (arranged numerically from left to right, top to bottom, with Site #1 at
the upper left and Site #8 at the lower right), as well as indicators of the TOPs
installed on each site. If no TOPs are installed on one or more of the sites, those sites
will be displayed as NO TOP.
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The area titled Device Action contains several controls that provide quick access to
the most commonly used programming actions, such as Program, Read Device,
Blank Check, Verify, Secure Device, and Test. These controls function identically
to the controls found in the Device menu, and are conveniently located on the Main
Programming screen for quick access.
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The File Menu
The first menu on the Main Programming screen is the File menu. The File menu has
two primary functions: loading data into RAM, and saving data from RAM.
Additionally, the PAL software can be terminated from this menu using the Exit
function.

The File menu
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File>Load
Selecting File > Load will produce the File Open dialog screen:

The File Open dialogue
The File Open dialogue allows the use of several different data formats including:
x
x
x

JEDEC standard (*.jed)
Altera POF format (*.pof)
Altera JAM format (*.jam)

Navigate the computer or network for the required data file, and select the <OK>
button. Once the file is loaded, the device may be programmed.
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File>Save As
There is also an option for saving the data in RAM as a data file. This can be helpful
when you have a master device but no data file, and you would like to create one. The
Save As dialogue allows the generation of data files as shown below:

The Save-As dialogue
You may save data files in standard JEDEC (*.jed) format only. Select a path and
filename for your file, then select <OK> to save it to the designated location.
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The Memory Menu
The second menu on the Main Programming screen is the Memory menu. The
Memory menu provides you with a method to view and/or edit the contents of
memory at any time before or after the programming operation:

The Memory menu
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Memory>Edit
Selecting Memory>Edit from the Memory menu will produce the following screen:

The Edit menu
The editor screen allows you to view the fusemap of the logic device under test, and
also allows you to edit the fusemap manually if necessary. As can be seen in the
figure above, a portion of the addressable fuse locations is displayed. If there is a “–”
symbol in any location, that fuse has been blown, while the “X” symbol indicates that
the fuse is still intact. Some of the additional controls on the screen include:
x
x
x
x
x
x

All to ‘–’—Blows all fuses in the device
All to ‘X’—Connects all fuses in the device
Set Line to ‘–’—Blows all fuses in the line that has been selected by the mouse
cursor; indicated by the highlighted line
Set Line to ‘X’—Connects all fuses in the line that has been selected by the
mouse cursor; indicated by the highlighted line
Home—Sends the cursor back to the beginning fuse location of the device
End—Sends the cursor to the last fuse location of the device
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x
x
x
x

Page (upper button)—Moves the cursor up one page of data each time the
button is pressed
Page (lower button)—Moves the cursor down one page of data each time the
button is pressed
Up—Moves the cursor up one line of data each time the button is pressed
Down—Moves the cursor down one line of data each time the button is pressed

An additional function that can be used from the editor screen is a simple fuse
location indicator. To use this indicator, simply place the mouse cursor over the
location in question, right-click the location with the mouse, and a window will appear
with the fuse location:

Right-clicking the edit screen will provide the fuse location under the cursor
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The Device Menu
The third menu on the Main Programming screen is the Device menu. This menu is
used to select the programmer operation for the device inserted:

The Device menu

Device> Program
This selection initiates the programming operation using the data that is stored in the
memory buffer. The device type selected must match the physical device in the
socket.
The device will first be checked for blank state or electrically erased. If the device is
electrically erasable, then an erase cycle will be automatically executed. If it is not
erased—and is UV-erasable or is a one-time-programmable (OTP) device—the PAL
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software will test to see if the pattern in memory can be over-programmed, where
additional data is programmed on top of the existing pattern in the device. If overprogramming is possible, then you will be prompted to “Skip blank check.” If you
select <Yes>, then the device will be over-programmed. If you select <No>, you will
receive a “Device not blank” error, and programming will stop.
After the blank check or erase operation is complete, the device will be programmed
using the algorithm defined by the manufacturer.
After programming, the device will be verified to confirm proper programming. If
there are any errors in verification, you can create a detailed report of the errors on the
screen (see Device>Verify later in this menu description). If the device vendor
specifies it, verification will be done at the VCC high and VCC low levels in accordance
with manufacturer’s specifications. After verification, if the security fuse command
was included in the JEDEC file, the security fuse of the device will be set (see
Device>Secure later in this menu description). If test vectors were included in the
JEDEC file, they will then be used to exercise the device (see Device>Test later in
this menu description).
You are informed of the sequence of steps in the programming operation by messages
on the screen. PASS/FAIL messages are provided in the status box indicating
programming status. A cycle counter is provided below the PASS/FAIL message area
displaying the number of devices programmed with the same content.
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Device>Read
This selection reads the contents of the device inserted in the socket and stores it in
RAM memory. After the data has been read into memory, the device type may be
changed to a compatible device without altering any data stored.

Successful completion of a READ operation
When using a Multisyte programmer, insert the device in the left-most TOP for the
read operation.
Note: Not all logic devices are capable of having their fusemaps
read by a device programmer. For those that are readable,
if their fusemaps have been placed in a SECURE condition,
the programmer will not be permitted to read the fusemap,
or the data will be encrypted such that each read operation
will return different results, perhaps even blank. This is a
security feature on a number of logic devices that ensures
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the data on the device cannot be read by unauthorized
personnel.

Device>Blank Check
This selection verifies that the non-electrically erasable device in the socket is in the
erased condition. The device in the socket is read and the contents compared to the
expected “erased” condition. The device type selected must match the physical
device inserted in the socket.
Electrically-erasable devices do not require a blank check operation. These devices
are automatically erased as part of the programming cycle.
Note: Blank Check operation is automatically performed during the
Program operation.

Device>Verify
This selection verifies the fusemap against the data file to ensure they match; any
verify failures will produce the following error:

Verify failure will prompt you to display a detailed report
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If you select <YES>, then the following screen appears:

Device error map following a verify failure
On the screen above, there are indications of the device locations and the failures
encountered. Blank spaces indicate locations where the data matched. Any space
with either a “–” symbol or an “X” symbol is an error, where the symbols indicate the
data that was expected in that location (“–” = blown fuse, “X” = connected fuse). The
<More> button provides more failure data if it exceeds the capacity of the window. If
a device has been secured, the Verify operation will not function correctly.

Device>Secure
This selection manually sets the security feature of the device inserted in the socket.
Many logic devices have optional security fuses that can be programmed after all
other fuses have been programmed. These final fuses prohibit reading (and
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verification) of the device. This means that the pattern set into the fuses of the device
is no longer readable by personnel who are not authorized to view the data pattern.
To manually secure the device, select Device>Secure. This must be the last step in
any programming sequence since the programmer expects to able to verify (read) a
device after programming.
In automatic mode (set with the Auto Security selection in the Options menu), the
security fuse(s) will be set during each programming cycle, after verifying and before
vector testing. If the JEDEC file contains the security fuse command (G1*), the Auto
Security mode is automatically enabled, and the Auto Security feature will be
checked in the Options menu.
The PAL software first programs the security fuse, then reads the array to verify that
the data no longer matches the array. The PASS message will only be displayed if the
array data is no longer readable.
Some devices disable preload if the security fuse is set. For these devices, Optima
PAL will run the test vector program before setting the security fuse during the
programming routine.
Some devices have a mode to read out the security fuse bit. Optima PAL can read this
bit and will indicate that the security bit is set. However, it will then perform a
double-check of the array contents to assure protection.

Device>Test
This selection performs vector testing of the device after programming. If a JEDEC
file with test vectors has been read into memory, then the device in the socket can be
tested for conformance with these test sequences with this command. This test will
also be invoked after the Verify operation in a programming cycle if test vectors are in
memory.
Note: If no test vectors are appended to the JEDEC file, this option
is not enabled.
The Test operation has three passes for each vector. Pass 1 sets up all input pins.
Any 0, 1, or X levels are presented to the device. All device outputs are set to read
mode. Optima PAL has a special method for handling the “X” (don’t care) level,
which is incompletely defined in the JEDEC specification and is often a cause of
vector test failures in other systems.
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Pass 2 applies any clocks to the device. The vector is scanned from highest pin to
lowest pin, and the clocks are output in that order. If a multiple click device requires a
controlled sequence of clocks, then there should be a separate vector for each clock.
It is impossible for a universal programmer like the Optima programmer to generate
simultaneous clocks on two pins. There will always be a time spacing between
multiple clocks in a test vector. Note that the “C” clock is normally low, and the “K”
clock is normally high.
Pass 2 also executes the preload function if a P or B vector is found. A P or B in pin1
of the vector indicates preload. Note that entering and leaving preload mode can
generate transient logic levels that can have other effects in a PAL design.
Pass 3 verifies the outputs of the devices against the test vector. If there are no errors,
the next vector is processed. If there are any errors, the good and bad data will be
displayed on the screen, and testing will stop unless continued by you.
Pins defined as “X” in the vectors are set as inputs to “0” unless the pin is determined
to be an unused output, in which case it is floated. High impedance outputs are tested
for incorrect “0” conditions, but not for low impedance “1” conditions. Test
simulation can also be used to verify a device after the security fuse has been
programmed (note that AMD PALCE-family of devices disables preload when
security is set).
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The Select Device Menu
The fourth menu on the Main Programming screen is the Select Device menu.

The Select Device menu
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The Select Device menu allows you to select the type of device you wish to program.
When selected, the Change Device screen appears:

Selecting the device to be programmed
In the example above, the Optima software has recognized the TOP48 is in use. The
devices listed are those that are supported by the TOP that has been installed. If the
device is not found on the list, then it is probably not supported by that TOP. Be sure
to check all of the Family classifications for the device in case the part number is in a
different location than expected. The Family categories are presorted in a number of
fashions to make searching for the device more efficient.
Because the information in the device selection dialogue is the exact same data that is
used to create the device list, the device menu name will be exactly as it is noted in the
device list. If you do not have a current device list, see Utilities>Creating a
Devicelist.
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The Options Menu
The fifth menu on the Main Programming screen is the Options menu.

The Options menu
Many programming operations are adjustable through the Options menu. Among
these are Continuity Check, Blank Check, verification parameters, Automatic
Security, Vectortest, and specific algorithm parameters.
Many of the options displayed in the Options menu are device-specific and may not
be available for all programming operations. For example, a UV erasable device may
not have the Blank Check menu item available to the user.
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Options>Continuity Check
If enabled, this selection checks for proper device alignment in the socket before a
programming operation. Alignment errors will present the standard continuity
warning message and allow you to <Display> the pins in question:

Displaying the device pin map following a continuity failure
Note: The Continuity Check option should always be enabled unless
there is a known reason to turn it off.

Options>Blank Check
This selection adds a Blank Check operation to the programming operation if the
device requires blank check. If a device is not blank during the programming
operation, a message will appear notifying you that the device in use is not blank. If
you choose to continue, the device will be over-programmed.
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This option is not available with electrically-erasable devices.
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Options>Verify Options
This selection is used to set the methods of device data verification after
programming:

Verification options in the Options menu
The following device verification options are available:
q
q
q
q
q

Verify Off provides no verification of the device after programming
Verify Normal provides a single-pass verify at nominal VCC for the device after
programming
Verify Low provides a single-pass verify at device-rated low VCC
Verify High provides a single-pass verify at device-rated high VCC
Verify Low and High provides a two-pass verify; once at device-rated low VCC,
and a second at device-rated high VCC
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Options>Auto Security
When selected, the security fuse(s) will be set during each programming cycle, after
verifying and before vector testing. If the JEDEC file contains the security fuse
command (G1*), the Auto Security mode is automatically enabled, and the Auto
Security feature will be checked regardless of initial condition.

Options>Vectortest
This selection is used to select the vector testing methods of the device after
programming. If a JEDEC file with test vectors has been read into memory, then the
device in the socket can be tested for conformance with these test sequences with this
command:

Vector testing options in the Options menu
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The following vector test options are available:
q
q
q
q
q

Off provides no vector testing of the device after programming
Normal provides a single-pass vector test at nominal VCC for the device after
programming
Low provides a single-pass vector test at device-rated low VCC
High provides a single-pass vector test at device-rated high VCC
Low and High provides a two-pass vector test; once at device-rated low VCC,
and a second at device-rated high VCC

Options>Algorithm Options…
This selection provides device-specific information about the device to be
programmed:

Algorithm options screen
Certain PAL devices can store an electronic signature that contains user-defined data
such as ID codes, revision numbers, or inventory numbers.
The electronic signature is always available to the user independent of the state of the
security bit.
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The Utilities Menu
The sixth menu on the Main Programming screen is the Utilities menu:

The Utilities menu
You can create a complete list of devices supported by the Optima Family
programmers by using the Utilities menu.
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Utilities>Create Devicelist
To create a device list, select Utilities>Create Devicelist. The following screen
appears:

Attention screen
Click <Yes> to continue.
A file titled “dev_pal.txt” is then created in your Optima directory. It lists all the
programmable logic devices supported for the installed version of Optima software.
The “dev_pal.txt” file is tab delimited and can be imported into an Excel spreadsheet.
Once imported, use Excel to filter the file to create a device list that meets your
specific needs.

Excel spreadsheet device list (portion)
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The Help Menu
The seventh menu on the Main Programmer screen is the Help menu:

The Help menu
The information available in the Help menu provides assistance with commonly used
features and functions of the Optima PAL software.
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SINGLE, GANG, AND SWAP PROGRAMMING
Optima programmers allow you to program devices one at a time or several at a time.
This flexibility greatly increases programming efficiency.
In single programming mode, one device at a time is programmed. Single
programming can be done on either Singlestye (Optima, Optima Light, or Plus 48) or
Multisyte (Dual, Quad, or Octal) programmers, using any of the optional TOPs.
In gang programming mode, multiple devices can be programmed simultaneously,
with the same data programmed into all devices. Up to eight devices can be
programmed using a single site TOP, and up to 32 devices can be programmed using
the FLASH TOP or TOP432.For gang programming, you need two or more identical
TOPs installed on your Multisyte programmer.
In swap programming mode, up to eight devices can be programmed in alternate (or
swap) cycles, with the same data programmed into all devices. For swap
programming, you need two or more identical TOPs installed on your Multisyte
programmer.
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Processing Devices in the Single Programming Mode
In the diagram below, the programmer in use is a Quad, with four TOPs installed:

A Quad programmer with two TOP48s, a TOP432, and a TOP84PLC installed
A Multisyte programmer (Dual, Quad, or Octal) is quite flexible as it allows several
different styles of TOPs to be installed simultaneously. While different TOPs styles
cannot be used simultaneously to program different devices, each TOP can, however,
be selected directly from the user interface when a different device style is required.
In the above configuration two TOP48s, a TOP432, and a TOP84PLC are installed.
The TOP48 on Site #1 (left-most site) is selected, and the programmer is set to
operate in Single mode. As it is currently configured, the programmer will process
devices one at a time on the selected TOP. If you require the use of the another TOP,
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simply select the TOP on Site #2, #3 or #4 by clicking its icon with the mouse cursor.
The newly selected site will be highlighted, indicating that it is the active site.
Note: If the programmer has different styles of TOPs installed,
selecting a site with a different style of TOP will prompt you
to select a new device. This is normal, as the software must
set up the programmer to process the different style of
device.
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Processing Devices in the Gang Programming Mode
Programming one device at a time can be time consuming. To expedite programming
devices, gang programming can be used with the Multisyte line of programmers
(Dual, Quad, and Octal):

A Quad programmer with four TOP48s installed
Here a Multisyte Quad is set to operate in gang mode. All four identical TOPs are
highlighted, indicating that they can be used simultaneously to program devices. It is
not necessary that all TOPs on the programmer are identical, but you do need at least
two identical TOPs for gang programming.
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To enter the gang-programming mode, perform the following:
1.
2.
3.
4.

Select the <single> button to enter the single programming mode.
Select the TOP style to be used for programming in the gang mode by choosing
the appropriate TOP on any site.
Select the <gang> button.
The LED to the left of the <gang> button will turn yellow, indicating it is waiting
for the next operation.
Select another identical TOP.
The software will automatically select all of the TOPs of the same style installed
on the programmer.
Note: The majority of devices are supported in gang more, but a
few devices, particularly logic devices, may not be
supported. Once you select gang programming, go to Select
Device and make sure the device is supported in gang
programming mode. You can also get this information from
Create a Device List.
Note: If you decide to change TOPs while the Optima software is
running, the programmer and software will not recognize
that the new TOP has been installed. To properly initialize
the TOP, end the current session and restart the Optima
software. Removing and replacing TOPs while the
programmer is turned on will not damage the programmer
or the TOPs.

Once the gang programming mode is properly configured, all of the selected sites are
used for simultaneous programming. When beginning the programming operation,
devices can be inserted into all of the selected sockets for programming.
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Processing Devices in the Swap Programming Mode
In some cases the swap-programming mode further increases efficiency in a
production environment. The swap mode is a modified gang mode, because it allows
you to load, unload, and label devices on half of the TOPs on the programmer while
the other half programs devices. As in gang programming, swap programming
requires that you have at least two identical TOPs installed on your Multisyte
programmer.

A Quad programmer with four TOP48s installed for swap programming
To enter the swap programming mode, perform the following:
1.

Select the <swap> button.
The LED beside it will turn yellow, indicating it is waiting for some user action.
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2.

Select one of the installed TOPs on the programmer.
The programmer will then select all of the TOPs that match the one chosen. The
indicator beside the <swap> button will turn green, indicating that the
programmer is ready for operation in the swap mode.

3.

In the Status section of the screen, enter the total number of devices to be
programmed in the text field labeled “total.”
Note: If the total number of devices to program is smaller than the
number of sites on the programmer, then the swap mode will
not be activated. The purpose of this mode is to enhance
productivity when processing a large number of devices.
The swap mode is purposely deactivated when processing
small quantities of devices.

4.

From the Device Menu, select Program, or select <Program> to begin the
programming operation.

5.

A window will appear instructing you to insert devices into the sockets with
flashing indicators; insert the devices, then select <OK>.

6.

While the first set of devices is being programmed, other sets may be prepared,
labeled, etc.

7.

When the programming of the first set of devices is complete, the software will
instruct you to remove the programmed devices, insert the new devices, and
select <OK>; the removed devices can then be labeled, prepared, etc.
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SET PROGRAMMING ON THE TOP432
The TOP432 consists of four 32-pin sockets, and is designed primarily for gang
programming of memory devices, though it can also be used for set programming (up
to four devices) of memory devices. A limited range of logic devices can also be
programmed using the TOP432.

A Quad programmer with a TOP432 installed in Site #3
As with all TOPs, the TOP432 operates independently of other TOPs when different
TOP styles are installed on a Multisyte programmer. The only operating difference
between the TOP432 and other TOPs is the number of devices supported by each.
Otherwise all TOPs operate seamlessly on the programmer.
Like other TOPs, the TOP432 may be used in gang with other TOP432s on the same
programmer, thus providing a large throughput of devices. Using the TOP432 in a
multiple-gang capacity is as simple as choosing the gang selection and choosing all
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TOP432s installed on the programmer. In this mode, all devices inserted into all of
the TOPs will receive the same programming information.
The TOP432 is unique because it has both gang and set programming capabilities. By
default the TOP432 is in the gang programming mode, where each device is
programmed with the same data. If you want to change to set programming, click on
the TOP432 icon. When the TOP432 icon appears, select SET-Mode programming.
In set mode, you have the option of 8, 16 or 32 bit programming mode:

Gang/Set mode screen
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8 Bit Mode
Select the 8 Bit mode when a large data file needs to be programmed over multiple
memory devices. In the example below the 64K file data is programmed into four
16K memory devices. The first 16K (0000-3FFF) is programmed into socket 1, the
second 16K (4000-7FFF) into socket 2, the third 16K (8000-BFFF) into socket 3, and
the fourth 16K (C000-FFFF) into socket 4.
The TOP432 creates the division of data automatically. The file is downloaded, the 8
Bit mode is selected and the programming operation is started.
Device Size
27C64
27C128

Socket 1
Socket 4
0, 1, 2…
0, 1, 2…

Socket 2
2000, 2001…
4000, 4001…

4000, 4001…
8000, 8001…

Socket 3
6000, 6001…
C000, C001…

16 Bit Mode
Select the 16 Bit mode when a 16 Bit data file needs to programmed into two 8 Bit
devices. In the example below the file data is a 16 Bit format. As the file data is read
during the programming operation, the TOP432 software places the low order bytes in
sockets 1 and 3. The high order bytes are placed in sockets 2 and 4.
Note: Often low order bytes are referred to as EVEN bytes and high
order bytes as ODD bytes.
The TOP432 creates the division of data automatically. The file is downloaded, the 16
Bit mode is selected and the programming operation is started.
Device Size
27C64
27C128

Socket 1
Socket 4
0, 2, 4…
0, 2, 4…
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Socket 2
1, 3, 5…
1, 3, 5…

4000, 4002…
8000, 8002…

Socket 3
4001, 4003…
8001, 8003…
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32 Bit Mode
Select the 32 Bit mode when a 32 Bit data file needs to programmed into four 8 Bit
devices. In the example below the file data is a 32 Bit format. As the file data is read
during the programming operation, the TOP432 software places low order data bytes
(D0-D7) in socket 1. Data bytes (D8-D15) are placed in socket 2, data bytes (D16D23) are placed in socket 3, and the high order bytes (D24-D310) are placed in
socket 4.
The TOP432 creates the division of data automatically. The file is downloaded, the 32
Bit mode is selected and the programming operation is started.
Device Size
any

Socket 1
Socket 4
0, 4, 8…

Socket 2
1, 5, 9…

Socket 3

2, 6, A…

3, 7, B…
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SOFTWARE MAINTENANCE PLAN
The Software Maintenance Plan (SMP) helps ensure that you have the latest device
support available on your Optima programming system. When you purchase the
Software Maintenance Plan, you are entitled to a full year of device support. You may
access this device support on the Data I/O web site or by contacting your Data I/O
Sales Representative for the latest software release on CD-ROM.
When programming devices, you may see the term “SMP” beside a device. The term
indicates that the current level of your software does not support that device, and if
you wish to proceed with programming, you will need to update your Software
Maintenance Plan.

Updating the Software Maintenance Plan
In order to update your Software Maintenance Plan, you will need to get an Update
Code Number from your Data I/O Sales Representative. Prior to contacting your Sales
Representative, locate and note the serial number for your programmer. The serial
number can be located by either running the Self-Test and Calibration program and
looking under Serial #, or by checking for the serial number on the back of the
programmer.
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Once you have your Update Code Number, follow this procedure for updating your
SMP:
Select Optima TEST from the Start menu:

Starting Optima TEST with Window 95 or Windows 98
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When selected, the following screen will appear:

Self-Test and Calibration screen
As prompted by the message, remove all devices or adapters from the sockets and
press any key to continue.
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Once devices have been removed, pressing any key will begin a series of printer port
tests to determine the computer’s ability to communicate with the programmer. When
the printer port tests are complete, you will be prompted to perform a Self Test.
Selecting the <YES> button will begin the Self Test. When the Self Test is complete,
the following screen is visible:

Self-Test and Calibration report
SMP expires after—The date that the current algorithm support expires. In this
case, after B/99.
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To update, select SMP Update from the menu bar. The following dialogue will
appear:

Enter the new Update Code Number here, and then select <OK>.
To verify that the SMP has been updated, exit the Optima Calibration Utility using the
Quit menu function, and re-start Optima TEST. Perform the steps as outlined above,
and ensure that the new features have been installed.
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